Torque CLI Installation#

Installation Prerequisites#

Torque CLI relies on a couple of industry-standard tools. Please install up-to-date versions of:

  • python 3.10+

  • pipx

  • git

Python 3.10+ Installation#

Check if you have Python 3.10 or later installed. To check your version run

python3 --version

For installation instructions visit Python 3 Installation & Setup Guide or Managing Multiple Python Versions With pyenv

pipx Installation#

pipx is used for installing and running Python applications inside isolated environments.

You can install via pip (requires pip 19 or later):

python3 -m pip install --user pipx
python3 -m pipx ensurepath

On MacOS you can use brew:

brew install pipx
pipx ensurepath

You have to restart the terminal after installing pipx to be able to access it.

For more detailed installation instructions please follow official documentation at pypa.github.io/pipx/installation

Installing Torque CLI#

Torque CLI is open source, and its source is at github.com/torquetech/torque-workspace-cli. To install the latest Torque CLI run:

pipx install git+https://github.com/torquetech/torque-workspace-cli

To check if Torque CLI installation was successfully installed, run:

torque

The expected output is workspace root not found!.